Por muito tempo procurava uma forma que pudesse montar uma tabela que pudesse entregar dados específicos de serviços em uma única tela e entregar de uma forma mais simples para comparar status e recursos.

Tinha que ficar configurando vários painéis diferentes e para comparar dados tabulares provenientes de diferentes fontes, era muito trabalhoso e de difícil visualização.

Então comecei a pesquisar uma forma que pudesse visualizar todos os itens que tinha necessidade na mesma dashboard, por exemplo, conseguisse colocar a saúde e métricas de todo o parque de um determinado grupo de host, ou de servidores de um determinado cliente…


No processo de instalação ou upgrade de banco entre versões do Zabbix, pode ser que encontremos o erro “[Z3005] query failed: [1118] Row size too large” quando utilizamos o banco de dados Mysql.

[Z3005] query failed: [1118] Row size too large. The maximum row size for the used table type, not counting BLOBs, is 8126.

Será preciso alterar o “innodb_strict_mode“ da base.

a) Desabilitar o innodb strict mode:

mysql -uroot -p'SenhaROOTMYSQL' zabbixdb -e "set global innodb_strict_mode='OFF';"

Sintaxe do comando:

  • u Usuario root
  • -p Senha Usuario root
  • zabbixdbbando_de_dado_zabbix
  • -e comando executado na base

b) Reinicie o processo do Zabbix server:

systemctl restart zabbix-server

Em caso de processo de upgrade de base, poderá acompanhar o…


Uma das novidades da ultima versão do Zabbix, 5.2, é a integração nativa com o Hashicorp Vault, com isso é melhorar a camada de segurança no armazenamento de informações secretas utilizadas no Zabbix, com isso deixamos toda a parte de armazenamento das credenciais sobre responsabilidade de um Hashicorp Vault externo. Assim não precisamos deixar macros ou em texto plano logins, senhas e informações sensíveis de forma insegura no frontend do Zabbix.

Para quem não conhece o Hashicorp Vault, acessem a pagina do projeto. LINK

Bora para HandsOn.

Nesse ambiente utilizei:

1 — Zabbix Server 5.2;

1.1 — Fiz toda a instalação por pacote…


#CaseComunidadeZabbix

Ambiente deste caso:

Server version: Debian 10

Banco: 10.3.18-MariaDB-0+deb10u1

Esta mensagem é demonstrada no arquivo de log do zabbix server, normalmente localizada em /var/log/zabbix/zabbix_server.log identificada por Z3001 (normalmente eventos relacionados a Banco recebem esta ID). Assim basta utilizar um utilitário para auxilio de leitura de logs (cat ou tail) em conjunto com um grep.

Erro

CAUSA:

Este erro mostra que limite de conexões simultâneas do banco foi atingido e as novas conexões não podem ser estabelecias no momento. Dependendo do tamanho do ambiente, tipos de monitoramento utilizado, integrações, consultas diretas no banco ou quantidade de pollers configuradas sem a devida…


#CaseComunidadeZabbix

Vejo muita gente perguntando sobre o que pode levar o processo do Zabbix-Server iniciar e depois parar. Normalmente é um simples Tunning do arquivo de configuração do Zabbix-Server.

Um usuário enviou a seguinte imagem:

Zabbix inicia e logo após para, podemos ver que ficou ativo 7s apenas.

Primeiro passo, partir para os logs do Zabbix, torne-se amigo dos logs (antes de procurar os amigos da comunidade rsrs), a ferramenta é estruturada para te apresentar eles os erros e como corrigir. Para quem não sabe, normalmente o arquivo de log do Zabbix fica em /var/log/zabbix/zabbix_server.log, utilize o utilitário tail para…


O Zabbix possui suporte nativo para monitoramento de VMware desde da versão 2.2.0. A comunicação é realizada através do protocolo SOAP (Simple Object Access Protocol), o Zabbix utiliza checagem simples (simple check) direto nos serviços web do VMware, possibilitando a criação de regras de descobertas para cadastro e monitoramento de Vcenter, Hypervisores, Datasources e Guests VMs de forma automática e de forma bem simples.

Preparando o Ambiente

Preparando o Ambiente

Pré-requisitos para este monitoramento são:

  • VMware 4.1 +
  • Libxml2 e libcurl — Momento de compilação, configurar com os parâmetros — with-libxml2 e –with-libcurl, para instalação via pacote, já vem configurado…

Neste artigo irei mostrar como podemos configurar o NGINX com o Certbot para aplicar automaticamente certificados SSL em ambientes de monitoramento, porem pode ser aplicado para outras aplicações.

Quando posso utilizar o nginx?

Ideal quando possui apenas um IP púbico e queira publicar apenas uma porta 443 e 80, principalmente quando se usa vários serviços, (Zabbix, Grafana, Gitlab, Proxymox, storage e etc). Além de não ter IPs públicos suficiente para publicação desses caras, dificilmente conseguirá dedicar cada serviço em um IP/porta porta diferente, além de ficar muito trabalhoso de se manter.

Nesse caso que entra em jogo o NGINX, além…


É muito comum precisarmos executar rotinas ou comandos dentro dos containers. Para isso existe um utilitário no daemon do docker, que facilita qualquer execução de comandos quando precisamos, chamado docker exec.

O comando exec possui a seguinte sintax.

docker exec <options> <container> <command>

Precisamos inicialmente identificar a ID ou nome do container, para isso, basta utilizar o commando “docker ps” ou “docker container ls”

docker ps
CONTAINER ID IMAGE COMMAND CREATED STATUS PORTS NAMES
2f92e332b379 debian "/bin/bash" 4 days ago Up 4 days keen_jepsen

Na primeira coluna é identificado a ID do container e na ultima o seu nome. (Obs…


Com a chegada do novo Zabbix agente escrito em GO (suportado como beta desde da 4.4), trouxe o suporte default de monitoramento de Docker com o Zabbix na versão 5. Neste pequeno artigo demonstro de maneira rápida e pratica como podemos realizar este monitoramento.

Ambiente utilizado:

Centos 7

Docker: 19.03.7

Obs: Todos os passos realizados neste artigo, foram feitos em laboratórios. Para produção, sugiro reproduzir várias vezes este, consumir bastante as documentações e verificar as práticas de segurança.

Instalado o Agente via Pacote de Instalação

Instale o repo para o pacote do Zabbix Agent 2 no seu S.O.

sudo rpm…

Recentemente, tive um problema ao instalar a versão mais recente do Docker no Centos 8, seguindo a documentação oficial e instalado via pacote, ele pede para que o pacote do docker 3.19 requer a versão do containerd.io maior que a 1.2.2.-3. Mesmo encontrando uma versão maior, ele apresenta o erro e não deixa instalar.

Problem: package docker-ce-3:19.03.8–3.el7.x86_64 requires containerd.io >= 1.2 .2–3, but none of the providers can be installed

bernardolankheet

Monitoring, DevOps Student and content creation!

Get the Medium app

A button that says 'Download on the App Store', and if clicked it will lead you to the iOS App store
A button that says 'Get it on, Google Play', and if clicked it will lead you to the Google Play store