Error ao instalar Docker no Centos8 — error package docker-ce-3:19.03.8–3.el7.x86_64 requires containerd.io >= 1.2 .2–3, but none of the providers can be installed

Recentemente, tive um problema ao instalar a versão mais recente do Docker no Centos 8, seguindo a documentação oficial e instalado via pacote, ele pede para que o pacote do docker 3.19 requer a versão do containerd.io maior que a 1.2.2.-3. Mesmo encontrando uma versão maior, ele apresenta o erro e não deixa instalar.

Image for post

Problem: package docker-ce-3:19.03.8–3.el7.x86_64 requires containerd.io >= 1.2 .2–3, but none of the providers can be installed

Image for post

Para corrigir:

Instale manualmente o pacote do container.io.

yum install -y https://download.docker.com/linux/centos/7/x86_64/stable/Packages/containerd.io-1.2.6-3.3.el7.x86_64.rpm
Image for post

Com o containerd.oi instalado, agora basta tentar novamente instalar o docker novamente.

Image for post

Para confirmar a instalação basta rodar um “docker –v”.

[root@localhost ~]# docker -vDocker version 19.03.8, build afacb8b

Até breve!!

Monitoring, DevOps Student and content creation!

Get the Medium app

A button that says 'Download on the App Store', and if clicked it will lead you to the iOS App store
A button that says 'Get it on, Google Play', and if clicked it will lead you to the Google Play store